Auto Swap Neutral does not actually swap, displaces
issueid=2426 10-31-2013 02:08 AM
Ancient Member
Number of reported issues by SirTheta: 77
Auto Swap Neutral does not actually swap, displaces

With the Auto_Swap_Neutral option, you actually wind up displacing most (all?) things (think pets) and not swapping with them. This is fairly annoying when attempting to walk down a corridor, for example: you have to keep pushing a monster down it/swap manually instead of breezing past.
Issue Details
Issue Number 2426
Project ADOM (Ancient Domains Of Mystery)
Category Linux
Status Fixed
Priority 7
Affected Version ADOM 1.2.0 pre 17
Fixed Version ADOM 1.2.0 pre 21
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




10-31-2013 05:22 AM
Ancient Member
It is supposed to work like the ':s' command when walking against a peaceful monster, I believe.

So, all that should happen is: the "Do you really want to attack/backstab *foo* [y/N]?" prompt should just be replaced with the ':s" command. In melee range obviously.

10-31-2013 06:48 AM
Ancient Member
Maybe someone else can confirm, but I think with Sage it has always been the case that with pets and companions, you displace them.

What Sage does is auto-swap when in plain ADOM you would get a message of the "Do you really want to attack the *foo*?" sort. With pets, you don't get that message (you displace them instead) and Sage isn't supposed to change anything.

So if this is only for pets/companions/slaves, I see no bug. If this makes you displace goodwives and the like, then it sounds like a bug, yes.

10-31-2013 07:54 AM
jt jt is offline
Administrator
Yes, it seems to be a bug.

10-31-2013 11:24 AM
Ancient Member
Al-Khwarizmi: sorry, when I said "think pets", I meant displacing [non-hostile/not-really-neutral] monsters, like you would displace a pet, instead of swapping.

10-31-2013 02:25 PM
Ancient Member
Oh, sorry. Probably you said it fine and the problem was my non-native English comprehension, I thought you were saying that the bug was with pets but I now see what you mean.

01-13-2014 08:04 PM
jt jt is offline
Administrator
Fixed.

+ Reply