Setting a Name in adom.cfg disables saving the game
issueid=2495 11-23-2013 01:11 PM
Senior Member
Number of reported issues by zasvid: 3
Setting a Name in adom.cfg disables saving the game
When playing an adom.cfg named character, saving takes me back to the game with no save generated

So, there's an option in adom.cfg to set the name of the character. When I use it and try to save the game, I get the normal post-save screen (a farewell message in upper left corner, "[Press SPACE to continue]" in lower right corner) and when I press space, I'm back in the game. Every time. Savefile doesn't get generated. It seems the only way to get out of the game is to either win without saving or quit (I haven't tried winning ;) ).

I've done a bit of experimenting to pinpoint the problem (changed ADOM versions, delete .adom.data a few times, fresh installs etc.) with a lot of revision of the adom.cfg file and everything is working fine until I add
Code:
Name          = X
When I do, I just cannot successfully save. I've tried different names, different placements of this line in adom.cfg file, different tabulation so it doesn't seem like a problem with the config file parsing... and the name shows up on my character.
Issue Details
Issue Number 2495
Project ADOM (Ancient Domains Of Mystery)
Category Linux
Status Fixed
Priority Unknown
Affected Version ADOM 1.2.0 pre 18
Fixed Version ADOM r48
Milestone (none)
Users able to reproduce bug 3
Users unable to reproduce bug 0
Assigned Users jt
Tags (none)




11-23-2013 03:05 PM
Ancient Member
I wonder, it almost sounds like you have an older leftover save with the same name. I have heard that Linux is totally different than windows, so I might just be on the totally wrong track.

11-23-2013 03:49 PM
Ancient Member
This is an interesting bug...

11-23-2013 04:05 PM
jt jt is online now
Administrator
Hm, which ADOM versions did you try? I've never used this configuration option before...

11-23-2013 07:43 PM
Senior Member
Quote Originally Posted by Stingray1
I wonder, it almost sounds like you have an older leftover save with the same name. I have heard that Linux is totally different than windows, so I might just be on the totally wrong track.
Nah, I've put totally new names into adom.cfg during testing and they still wouldn't save at all. savedg folder in .adom.data remained totally empty.

Quote Originally Posted by jt
Hm, which ADOM versions did you try? I've never used this configuration option before...
I've tried Ubuntu and Debian builds of ADOM prerelease 18 without NotEye and both had this behaviour.

11-23-2013 07:49 PM
jt jt is online now
Administrator
Ok, I thought you meant older ADOM versions like 1.1.1 or 1.2.0 Prerelease 5.

This problem was probably introduced by adding the "death menu".

01-19-2014 12:49 PM
jt jt is online now
Administrator
Does anybody really use this configuration option? I vote to remove it.

Maybe it should be renamed to "Default_Name" and only used for character creation.

04-21-2014 07:20 AM
The Creator
Quote Originally Posted by jt
Does anybody really use this configuration option? I vote to remove it.

Maybe it should be renamed to "Default_Name" and only used for character creation.
It's an ancient one that people asked for at the dawn of ADOM time (around 0.6.0 or so?).

04-21-2014 07:57 AM
Ancient Member
I had a similar problem in windows 32bit prerelease 20 not Noteye version, but I am not sure if it was due to name, i am not sure i had the name config set in the cfg file, but had a lot of other options.

I had to remove the adom dat folder to fix it(and quit a fairly promising wizard in the process).

Tweaking the cfg file has some issues though anyway. I have the class set as wizard but it still asks me to chose a profession every time.

Also, i am not sure how the color of id items should change, but it is definitely not changing anything atm.

05-19-2014 03:53 PM
Member
This definitely due to setting a Name = X in adom.cfg
Not only does this set the name of all your new characters (which is a time-saving feature that I don't think I am alone in supporting),
but it also automatically loads any saved game with that name, skipping the opening menu.

Here's the bug: when you save the game, ADOM now no longer exits but instead goes to the post-game menu. Before it does that, it checks adom.cfg and, if a name is set, it loads the save of that name.
Which is the one you have just created.

I think we should lose the "automatically load a game" function of the "Name" parameter in adom.cfg. The usual "The name 'X' is already in use. Try another name." prompt would be fine instead.

05-24-2014 05:20 AM
Member
I thought I could get around this by setting "Name = X", and then renaming my character when he proved worthy of a name.

But setting "Name = X" means I cannot restore a saved game that has a different name!

06-03-2014 05:15 AM
Member
I actually use this setting just for the auto-load (I'm lazy and only ever have one character at a time), the only reason I've avoided this issue is I haven't taken the time to alter my config files in the prereleases (I don't want to repeat the changes with each release). After a quick test I found that I can reproduce the issue. Hopefully this can be fixed before the final release but it's not that big of a loss if the functionality is changed.

06-29-2014 05:07 AM
Senior Member
Same issue here. Have to manually copy the file to another place after saving (before pressing space); can only leave the game via Quit.

07-04-2014 07:46 PM
jt jt is online now
Administrator
Fixed. If a PC name is configured in adom.cfg ADOM now quits after saving the game.

+ Reply