Map does not scroll reliably when game first starts
issueid=349 08-14-2011 10:40 PM
Junior Member
Number of reported issues by anoddlad: 9
Map does not scroll reliably when game first starts
Very minor irritation

When I first load a character, attempting to head directly west results in me walking off the screen without the map scrolling to keep me in sight.
Heading up and east, out of the Drakalor pass, triggers scrolling appropriately and allows me to reenter the Drakalor chain and explore the western part of the map.
I note the map seems to generate quite far over to the left of the screen - perhaps the game doesn't realise where it generates the map initially? I.e. it doesn't trigger the map scrolling because it thinks I'm still on the screen.
Issue Details
Issue Number 349
Project ADOM II (formerly known as JADE)
Category UI
Status Fixed
Priority 8
Affected Version JADE 0.1.3
Fixed Version (none)
Users able to reproduce bug 7
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




08-17-2011 05:20 PM
The Creator
Hmmm... never happened to me. Can you explain a way on how to reproduce this?

08-17-2011 05:56 PM
Junior Member
It just happens every time when I start ADOM with a new character. Must be specific to my computer somehow?
I can email you screen dumps if you like.

08-17-2011 06:13 PM
Junior Member
Additional information:
My character always appears on the 25th space across by the 12th space down. This is consistent whether starting a new character, or reloading an old one. Hence moving 25 squares left, or 12 up, puts me off the screen.
The screen does not scroll until I move at least 42 squares left, or 16 squares up. After one scrolling-event is triggered, all is fine - character is placed more centrally, and scrolling is triggered appropriately.
Resizing the screen appears to *sometimes* make the next off-screen move trigger scrolling.

08-18-2011 08:22 PM
The Creator
Can you tell me more details about your system? Like
- operating system (type, version, patch level)
- screen resolution
- video board
- java version (type "java -version" at the command prompt)

This is really strange :-)

08-18-2011 08:33 PM
Junior Member
Quote Originally Posted by adom-admin
Can you tell me more details about your system? Like
- operating system (type, version, patch level)
- screen resolution
- video board
- java version (type "java -version" at the command prompt)

This is really strange :-)
I have just reproduced the issue. The steps are like that:

1. Generate character. --> Main window appears. It is maximized.
2. On the world map, go 13 tiles to the west (do not enter the village! it's important!). --> World map doesn't scroll when moving west. Character can go outside of visible map area. See attached screen.

Win XP 64-bit SP2, JRE 1.6.0_26, 1680*1050

08-19-2011 08:52 AM
Junior Member
Win 7 Ultimate 64-bit
Core i5 750
Gigabyte GA-P55-USB3 mobo
ATI Radeon 5700 by MSI
Dual screen setup - primary 1920x1080, the secondary monitor is slightly smaller.

08-19-2011 08:59 AM
Junior Member
Windows is currently up to date - no specific patch version, can give you a list of minor updates if you like ;)
Java is version 6 update 26. (6.0.260) according to my system information.

08-19-2011 06:59 PM
The Creator
Frustrating. On my Mac it doesn't happen (and I need to move a lot farther than 13 steps before there is even a need to scroll). I guess I need to spend more time with a Windows system on that problem...

08-21-2011 11:27 AM
Junior Member
Was going to start a new tread, but stumbled upon this one, similar to what I've encountered. Although it's not only "when game starts" for me.
The issue is that my character wanders off the screen, eight steps through the void till the actual map scrolling happens.
The way to reproduce: enter Terinyo (which brings me near the right corner of the village, with a character on the right side of the screen), and then save/quit/reload, which makes my @ to be centered on. After that a hero can go over the left edge and be invisible (even to me), attachment included.

Fix: running on 64-bit Windows 7

08-22-2011 07:32 AM
The Creator
Did any of you manually resize the window when this happens?

08-22-2011 08:04 AM
Junior Member
Tried this - sometimes this triggers scrolling on the next move, sometimes it doesn't. Didn't trial it extensively (I have to close and reopen the game any time I want to try one thing!).

08-22-2011 08:05 AM
Junior Member
Pop round to Wales, and I'll let you investigate on my computer ;)

08-22-2011 11:34 AM
Junior Member
As I wrote above, I was able to reproduce the original bug on Windows, but I've encountered a similar issue as well. I was able to reproduce my (but not the original one) issue on Ubuntu, build for amd64. (And no, I did not resize any windows in both cases)

I reproduced the reloading issue as follows:
-- found a city which was longer than the width of my screen
-- saved and exited while standing in the far right corner of the map as below:



-- and after reloading there I was, at the center of the screen:



Could it be that the code still thinks that @ is at the right corner, and delays scrolling accordingly?

08-23-2011 11:46 AM
Junior Member
This affects me aswell. Fixed it by changing the zoom level from the original 8 to 10 then changing it back to 8.

08-23-2011 12:01 PM
Junior Member
I got this problem as well, on the windows PC at my parent's place. On my standard ubuntu laptop this never occurs.

The problem fixes itself by entering an area, then leaving it again.

08-23-2011 12:02 PM
Junior Member
Quote Originally Posted by Phobos
Fixed it by changing the zoom level from the original 8 to 10 then changing it back to 8.
Genius! Thanks.

11-06-2011 07:26 PM
Junior Member
I'm having a similar issue that did not appear until 0.2.0. I entered Terinyo and started in the south center, but screen displayed me as offscreen to the west.
I could only see twelve spaces high of visible play area with the rest being blank, though I could move around freely.
Moving west results in the screen not moving, text appears as I move past trees etc.
If I walk east, I show up as normal. Walking out of Terinyo, re-entering, and moving south triggered a larger view and the issue disappeared.

Stuff that might be relevant:
Windows 7
1680x1050 resolution

11-09-2011 11:36 AM
Junior Member
I'm getting the exact same issue. I walk down from Terinyo (without entering), go through the little grass pass and continue off the screen to the west.

- 1920x1200 (Maximized on one of twin monitors - the other 1024x768)
- Vista Ultimate
- Anything else you need?

11-09-2011 11:39 AM
Junior Member
And - no change of size. Maximizes on start. And Windows in 64 bit

05-02-2012 07:27 AM
The Creator
Does this problem still happen for anyone with ADOM II 0.2.3?

+ Reply