Ice level display is completely broken in graphical mode
issueid=3822 08-25-2015 09:06 PM
Member
Number of reported issues by kapsi: 1
Ice level display is completely broken in graphical mode
Screen is corrupted when entering ice level

I can't post a screenshot because print screen doesn't work (captures Windows desktop instead), but basically after entering the ice palace from wilderness, music changes but screen stays the same, except for a white stripe on the left of the screen. I use Windows 10. ADOM r60.
Also there's the "adom.exe stopped working" box after quitting the program, every time.
Issue Details
Issue Number 3822
Project ADOM (Ancient Domains Of Mystery)
Category Windows 10
Status Fixed
Priority 1 - Highest
Affected Version ADOM r60
Fixed Version ADOM r61
Milestone Initial Steam Release
Users able to reproduce bug 4
Users unable to reproduce bug 0
Assigned Users Zeno
Tags (none)




08-26-2015 05:35 PM
Member
Same for last level of the tom of high kings, which breaks the game.

08-27-2015 07:41 PM
Junior Member
I second to that. Must switch to ascii in ICD :(
windows 8 adom r60 will post screenshot ASAP.

08-27-2015 08:39 PM
Junior Member

08-28-2015 06:24 AM
jt jt is offline
Administrator
@Zeno: I get the following error:

handling NotEye error #15: error running scrcopy [./games/adom.noe:1780: attempt to call global 'bord' (a nil value)]

This happens both in fullscreen and non-fullscreen mode after walking to the left. It looks fine at the start of the level (on the right side).

08-28-2015 09:07 AM
Member
Same in the tower of eternal flames.

09-01-2015 02:08 PM
Senior Member
Happens to me as well. When I switched to different tile modes (those downscaled ones, I don't remember their names), I got a map of my last wilderness encounter instead. ASCII works fine.

09-03-2015 05:24 PM
Junior Member
I second kapsi's reply - it also happens in the TOEF and even in the Underwater dungeon it has been happening to me, as well.

09-24-2015 08:10 PM
Ancient Member
Should be fixed.

03-19-2016 11:18 PM
Junior Member
RE: Black screen display problem - it's not fixed.....

Version r60 1.15.2 Free version -

Lowest level of High Kings - getting that platinum ring - The whole screen is black.
I navigated using the little inset screen - killed the skeletal king - left, and as soon as I started going back to the right of the screen the whole screen was back to normal, displaying properly.

Then I got close to the winding passage leading to the stairs, and the whole screen went black again.


Left the cave of the High Kings, and stopped by the Tower of Eternal Flame - stepped in and the whole screen was black again.

ADOM 1.2.0 Prerelease 23 didn't have this problem...

03-20-2016 01:59 AM
Senior Member
It's fixed in the next version...

Edit: to be precise, as the issue lists the bug was reported in r60 and is fixed in r61. Versions past r60 are Steam-only until/unless a new public version is released.

03-29-2016 12:16 PM
Junior Member
This is disappointing.
I usually kill myself with stupidity, typos, or other random mistakes, and rarely get a character very far.

I finally have a nice run going...
In sequence, I visited Tomb of the high kings, Water Dragon level and then Ice Palace. All suffered from this.
I then realized it was a bug.


While I'm glad it has been fixed in later versions, I'm sad my version has this bug.
While I'm glad ascii mode still works, I must needs learn to play on that screen.

+ Reply