Monsters only take 1 turn when bookcasting
issueid=4457 09-14-2016 05:33 PM
Ancient Member
Number of reported issues by Blank4u47: 25
Monsters only take 1 turn when bookcasting

I havnt tested if this applies to other effects with energy cost yet, but when next to a monster or monsters and bookcasting, the monster only attacks once, even though my action correctly displayed as 3000 energy. Will need to test this out with other energy cost related effects.
Issue Details
Issue Number 4457
Project ADOM (Ancient Domains Of Mystery)
Category All Steam Versions
Status Fixed
Priority 3
Affected Version ADOM r69 (v2.2.3)
Fixed Version ADOM 2.3.3
Milestone Important Bugfixes
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




09-14-2016 11:24 PM
Senior Member
Seems to also be the case with the mighty and tremendous blow barbarian abilities.

03-17-2017 05:17 PM
Senior Member
The issue seems to be that the energy cost penalty is applied a turn too late. If you use mighty blow against a monster, it gets one attack. If you use a normal attack against the monster the next turn, it gets 2-3 attacks. The same applies to moving and triggering auto-pickup (1 attack the turn you move and pick up, 2 attacks the turn after), and to book-casting (1 attack the turn you book-cast, 3 attacks the turn after).

03-18-2017 05:07 PM
Ancient Member
Interesting! But I think the bookcasting specifically got fixed, I havnt tested mighty blow in the new version though.

03-18-2017 07:55 PM
Senior Member
Quote Originally Posted by Blank4u47
Interesting! But I think the bookcasting specifically got fixed, I havnt tested mighty blow in the new version though.
None of the things mentioned here have been fixed in r72.

03-23-2017 03:24 PM
Senior Member
There's also a bug where the last energy cost display is set to 1000 when you perform actions that don't take any time (adjusting tactics, looking at inventory, etc): 4618. It turns out this isn't just a display bug; since you pay energy costs a turn late, you can use this to set the last energy cost to 1000 and avoid ever paying for higher energy cost actions.

03-23-2017 08:38 PM
Ancient Member
Whoa damn. You are a bug wizard!

09-13-2017 06:28 PM
Issue Changed by adom-admin
  • Milestone changed

09-19-2017 05:34 PM
Senior Member
Appears to be fixed in 2.3.1. While the issue with non-actions changing last energy persists, it is now only a display issue.

Yesterday 09:17 AM
Issue Changed by adom-admin
  • Issue marked as addressed
  • Addressed version changed from Unknown to ADOM 2.3.3
  • Status changed from Unconfirmed to Fixed

Yesterday 09:17 AM
The Creator
Setting this to fixed in 2.3.3 so that it shows up in some changelog.

+ Reply