ADOM 3.0.6 (release 88) (Ubuntu 16.04.3 / 64 bit) does not run out of the box in the newest Ubuntu 17.10
issueid=5910 01-09-2018 04:16 PM
Junior Member
Number of reported issues by tuomosipola: 1
ADOM 3.0.6 (release 88) (Ubuntu 16.04.3 / 64 bit) does not run out of the box in the newest Ubuntu 17.10
ADOM 3.0.6 (release 88) (Ubuntu 16.04.3 / 64 bit) does not run out of the box in the newest Ubuntu 17.10

ADOM 3.0.6 (release 88) (Ubuntu 16.04.3 / 64 bit) does not run out of the box in the newest Ubuntu 17.10.

What I did:
Unpack the zip file.
Start adom $ ./adom

What I expected:
Adom would run normally

What I got instead:
Adom does not run because, e.g., libpng and libwebp are too new. Adom is built against older version of the packages that do not come with Ubuntu 17.10.

It is quite sensible to offer Ubuntu LTR (such as 16.04.3) versions of the game, however, it would be nice to have one running out of the box in the newest Ubuntu release. Gathering old versions of packages takes time, might not be possible and could make the package management broken. I don't even know which packages are affected, at least libpng and libwebp.

If possible, I would appreciate support for the newest Ubuntu versions.
Issue Details
Issue Number 5910
Project ADOM (Ancient Domains Of Mystery)
Category Linux (NotEye)
Status Fixed
Priority 3
Affected Version ADOM 3.0.6
Fixed Version ADOM 3.0.7
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




01-15-2018 06:44 AM
jt jt is offline
Administrator
I've updated my build VMs to Ubuntu 17.10. The next release will work. Maybe we will also build a version for the last LTS version.

+ Reply