I'm new to ADOM. Although technically I played it first, the only roguelike I actually have some experience with is Angband.

I'm trying to install ADOM's noteye version on my version of linux. Unfortuantely, I run devuan, so I think none of the right packages are getting installed when I run ADOM. I've been trying to install each dependency one at a time but it's a huge pain. ASCII works fine, but I want to use the NotEye version as well.

Right now, trying to run ADOM noteye gives me the following:

./adom: /lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by ./lib/libnoteye.so)
./adom: /lib/x86_64-linux-gnu/libncurses.so.5: no version information available (required by ./lib/libnoteye.so)
./adom: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./lib/libnoteye.so)
./adom: /usr/lib/x86_64-linux-gnu/libxkbcommon.so.0: no version information available (required by ./lib/libSDL2-2.0.so.0)
I think I have all the files installed (these lines seem to be the only problem lines after looking at ldd), but ADOM is not recognizing them because of my distribution.

Thanks for your help!