Wizards not charging wands after all
issueid=117 04-08-2010 04:24 PM
Member
Number of reported issues by lotuskip: 2
Wizards not charging wands after all

I have not tried this myself, but remember it being mentioned (perhaps someone can confirm?): if you use the wizard ability to recharge a wand and enter '0' (zero) at the "How much power would you like to expend charging the wand?", this causes the game to crash.
Issue Details
Issue Number 117
Project ADOM (Ancient Domains Of Mystery)
Category Unknown
Status Fixed
Priority Unknown
Affected Version ADOM 1.1.1
Fixed Version ADOM 1.2.0 pre 1
Milestone (none)
Users able to reproduce bug 1
Users unable to reproduce bug 1
Assigned Users (none)
Tags (none)




04-08-2010 05:44 PM
Ancient Member
Uh, I thought it just did insane damage to the player as he tried to give the wand too much charge?

04-08-2010 05:48 PM
Member
Oh, oh. My bad. Still a bug, I suppose.

04-11-2010 07:56 PM
nathrakh
I don't think it's a bug. It is a feature.. (altough badly described).

04-12-2010 02:52 PM
Ancient Member
No, it's a terrible bug. If it was a feature, it would be a terrible feature. Entering "0" at that prompt can be perfectly well understood as the player saying "Oh, nevermind, I won't charge the wand". It shouldn't result in an instadeath.

02-01-2012 07:55 PM
jt jt is offline
Administrator
If the player did not enter a value, the default value 100 was used. This could result in overloading the wand. Now the default value is 0 which aborts the dialog.

+ Reply