can't restore saved games
issueid=1369 12-02-2012 01:30 PM
Ancient Member
Number of reported issues by Evil Knievel: 6
can't restore saved games
On debian build,, pressing [r]estore in the game menu results in crash of the game.

I can play, save, but when i come back to restore, i get

Fatal error:
"Could not restore version data."

I tried to erase all, and to install a new executable, did not help. Adom creates an "adom.err" file - i can post one if you like.
Issue Details
Issue Number 1369
Project ADOM (Ancient Domains Of Mystery)
Category Linux
Status Fixed
Priority 5 - Medium
Affected Version ADOM 1.2.0 pre 5
Fixed Version ADOM 1.2.0 pre 6
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

12-02-2012 07:57 PM
jt jt is offline
Can you please check if there are some odd files in the "" directory? Can you please upload the contents of your "" directory?

Erasing the "" should help in any case, it's odd that it doesn't.

12-03-2012 09:40 PM
Ancient Member
Here you go. There is nothing but adom.err, and the savegames in that directory. I deleted and recreated everything but the .HISCORE files and the savegames themselves. I tried to reload savegames created before and after recreation.

12-03-2012 09:41 PM
Ancient Member
contents of

EDIT: i uploaded the file. I don't see it here, though
EDIT: ok allright

12-04-2012 08:36 PM
jt jt is offline
There is a "Gamli.svg" save game with a size of 0 bytes in the "savedg" directory. This file causes the error message and removing it should fix the problem. I've already changed the routine for the next prerelease, so that files which are too small are ignored.

12-06-2012 03:34 PM
The Creator
As Jochen said.

+ Reply