ADOM command line option for displaying hiscores crashes it
issueid=2499 11-25-2013 07:10 PM
Senior Member
Number of reported issues by zasvid: 3
ADOM command line option for displaying hiscores crashes it
Trying to start ADOM with command line option -s to display hiscores results in a crash.

I tried to launch ADOM with a command line option -s to view the highscores and I got this:

*** Signal 11 was raised.
and then

Now ADOM will exit with the default action for the given signal. Should your
screen display some kind of register dump (as it e.g. does under DOS) please
note it *completely* for your bug report. 

Segmentation fault (core dumped)
I've checked out some other command line options (-b, -d, -D, -h, -l <savename>, -m, -o, -v) and they worked fine.

Tried it with ADOM 1.1.1 and it worked without a crash, though didn't actually display any hiscores - I guess the command line option broke when hiscore file format was changed (if I recall correctly that it did).
Issue Details
Issue Number 2499
Project ADOM (Ancient Domains Of Mystery)
Category Linux
Status Fixed
Priority Unknown
Affected Version ADOM 1.2.0 pre 18
Fixed Version ADOM 1.2.0 pre 21
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

11-26-2013 07:48 PM
jt jt is offline

+ Reply