Game crashes regularly when using inventory item filter
issueid=2900 04-27-2014 09:32 PM
Senior Member
Number of reported issues by sylph: 26
Game crashes regularly when using inventory item filter
Using NOTeye, game regularly crashes on item filter - more than 50% of the time.

I regularly get this crash:
when using an inventory filter. This is despite not having marked/named any items. Windows 7.

When the crash occurs, none of the options put me into a working instance of the game - I just get a blank screen, and next time I press enter, I get a crash to desktop. Savegame file is, luckily, retained.
This happens extremely regularly. Definately more than half of the time I use the item filter feature (although so far it seems to happen with more likelihood the larger my inventory is).

Edit - actually, it seems more like about 30% of the time (in pre22)
Issue Details
Issue Number 2900
Project ADOM (Ancient Domains Of Mystery)
Category Windows 7 (NotEye)
Status Fixed
Priority 2
Affected Version ADOM 1.2.0 pre 22
Fixed Version ADOM r48
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

04-28-2014 06:05 AM
The Creator
Can you describe a series of actions (e.g. key presses) with a newly created character that makes this reproducible?

04-28-2014 08:07 AM
Senior Member
It's hard to reproduce the bug with a new character. I just had a go, but I can't get the bug to occur with a new (level 1) character - I suspect there has to be a larger inventory for the bug to occur, but I suppose it could also be something to do with the presence of monsters or items on the ground! I guess I could stream/record the next few times I play, and try to make notes of exactly what is increasing the chances of it happening.

If this helps at all, though, I *can* confirm that if it crashes, and I reload the (automatically generated) savegame at the point of the crash, it will crash again (nearly 100%) if I try to enter the item filter after loading. If I play on without using the filter feature straight away, then later on it will have a chance of working (and a large chance of crashing), so it could well be a specific situation on the current level or character causing the crash...

04-28-2014 08:11 AM
Ancient Member
I suppose attaching the save and steps to reproduce from the save would also be useful for the debugging.

04-28-2014 08:33 AM
Senior Member
Quote Originally Posted by Al-Khwarizmi
I suppose attaching the save and steps to reproduce from the save would also be useful for the debugging.
Yep, good point, I'll do this! (in work at the moment, so can't really play and reproduce the bug for a few hours.)
I have a feeling the save might work correctly for other players, given that it seems I'm the only tester that's having this problem so far. I wonder if it's anything to do with my laptop having switchable graphics or something? Either way, I'll be sure to post the savegame and steps to reproduce next time.

04-28-2014 09:31 PM
Senior Member
That's a savegame file that I can use to recreate the bug semi-successfully.

Here's a video (youtube) of me playing around a little, and getting the bug to occur a few times:

i get the bug both in fullscreen, and in windowed mode.

04-29-2014 11:23 AM
Senior Member
To add - if I play for 5-10 minutes, then try to use the item filter, it will crash about half the time. If it *doesn't* crash, then I can generally filter as many times as I like, getting no crashes. If it *does* crash, then it's likely to crash again and again as I reload the savefile. Switching from fullscreen to windowed mode seems to break out of this cycle, and often if I'm getting crash-after-crash upon reloading a savefile and filtering, I can alt+enter to play in a window, and then the filter often works.

This doesn't mean to say, however, that the game never crashes when playing in a window. It sometimes does!

I set my noteye FPS to high values (60fps or higher) - I wonder if this could be having some effect?
I also run fullscreen in 800x500 (ie, not native resolution)

04-29-2014 07:02 PM
jt jt is offline
Thanks, sylph! I could reproduce the problem once (!) directly after setting the fps to 60 (in my Windows XP VM). Maybe you should try setting the fps to 30 and see if things improve?

Maybe Zeno has an idea what might be causing this problem... I've never seen it before.

05-06-2014 09:20 AM
Senior Member
Just to note - I've tried as low as 15fps... Still get the problem, and it's still extremely common, to the point of making the item filter pretty much unusable. :/

05-10-2014 02:02 PM
Senior Member
Another update - If I change display modes (such as pressing alt+enter to go to windowed mode), then instantly press enter to open the item filter, it works. Same if I turn on opengl then immediately filter. *Total* pain to do it every time I want to filter, and not worth the hassle half the time, but just thought it might help find what's causing it.
Real shame, because the item filter was the single feature I've found most exciting from all the recent features mentioned... :(

05-10-2014 02:20 PM
jt jt is offline
It might be related to the item graphics that are shown in the inventory (the ones shown if you move the mouse over an item), so Zeno has added an option to disable them (in the "ADOM specific options"). It would be great if you could test it in Pre 23 (out *soon*) and give us some feedback. Thanks! :)

05-10-2014 03:34 PM
Senior Member
Ok, sounds interesting.
I do love those graphics, too, though! Would be a shame to lose them, but nowhere near as important as an item filter!

05-10-2014 07:08 PM
Senior Member
jt - I think you might just be right! By making sure my mouse cursor is not on one of the items in the main window when I press the filter key, I can stop it from crashing! So far it's worked 100% (about 50 tries so far), while having the mouse pointer over an item has resulted in almost guaranteed crashing!

05-10-2014 07:21 PM
jt jt is offline
Ok, I have the same effect with the NotEye version for OSX... so hopefully we can find the real cause of the problem. It's very strange that no one else had this problem...

You should consider updating to pre23 now and using the new option to disable the graphics. :)

05-11-2014 09:05 AM
jt jt is offline
Fixed. Too bad the bugfix is too late for Pre23. :(

+ Reply