Segmentation fault/crash/hang when launching adom while (or adom_dat) doesn't exist
issueid=3124 07-13-2014 05:06 PM
Ancient Member
Number of reported issues by Sami: 91
Segmentation fault/crash/hang when launching adom while (or adom_dat) doesn't exist

On 64 bit ubuntu version (without noteye) the game segmentation faults right after launching the game if ~/ does not exist.
64 bit ubuntu version (with noteye) just hangs up if ~/ does not exist.
And windows version crashed when I tried to run it with wine without adom_dat.

Running on 64 bit Linux Mint 16.
Issue Details
Issue Number 3124
Project ADOM (Ancient Domains Of Mystery)
Category All
Status Fixed
Priority 1 - Highest
Affected Version ADOM r48
Fixed Version ADOM r49
Milestone (none)
Users able to reproduce bug 2
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

07-13-2014 05:55 PM
Senior Member
I always delete my adom_dat folder when a new ADOM is released in order to rebuild the adom.cfg file and there was a similar crash error when running ADOM r48 NotEye verision on Windows 7 for the first time.

It says the application has stopped responding and provides the following:

Problem signature:
Problem Event Name: APPCRASH
Application Name: adom.exe
Application Version:
Application Timestamp: 53c24617
Fault Module Name: adom.exe
Fault Module Version:
Fault Module Timestamp: 53c24617
Exception Code: c0000005
Exception Offset: 00094905
OS Version: 6.1.7601.
Locale ID: 4105
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

However the adom_dat folder gets created correctly so this crash only occurs the first time ADOM is run.

07-13-2014 07:29 PM
Ancient Member
Same here, under Windows 7 64-bit. ADOM r48 crashed the first time I run it, went fine the following times.

07-14-2014 06:13 PM
The Creator

+ Reply