Clicking makes the level up (more) prompt fade out
issueid=3542 01-10-2015 05:58 PM
Ancient Member
Number of reported issues by Ravenmore: 38
Clicking makes the level up (more) prompt fade out
Levelling up now requires pressing space to continue. But if you click anywhere the message will fade out and still wait for a space key.

As in the summary. Obvious downside is that the player can click past the prompt and be left with a "stuck" game. Still waiting for the space key but without any visible prompts.

Clicking should probably do nothing in this particular case.
Message should stay on top until the required action is performed.
The massage should have "press space to continue" somwhere in it.

This also applies to the death prompt.

Interestingly enough Y/n prompts are not subject to this and stay on top.
Issue Details
Issue Number 3542
Project ADOM (Ancient Domains Of Mystery)
Category Linux (NotEye)
Status Fixed
Priority 1 - Highest
Affected Version ADOM r54
Fixed Version ADOM r58
Milestone Initial Steam Release
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users adom-admin, Zeno
Tags (none)

03-20-2015 06:21 AM
jt jt is offline
Seems to work fine on R57 (on OSX).

03-20-2015 06:58 AM
Ancient Member
Just updated my files and checked. On Win 8.1 still the same thing happens:

- You level up, you get the prompt
- Just left click a couple of times anywhere on the screen.
- Message fades out, and you're left with no indication why no keys or buttons are working (except space).

And just to be sure: note that this applies only to level up/death prompts, while any Y/n questions work fine.

03-20-2015 04:15 PM
jt jt is offline
Re-opening... it seems to work fine on OSX and Zeno said he couldn't reproduce it, so I closed the issue.

03-22-2015 06:37 AM
Ancient Member
Might be windows-specific then. Happens on my 8.1 machine. Tried it windowed and fullscreen, always the same thing.

06-24-2015 06:19 AM
jt jt is offline
It seems I can close this one, Ravenmore?

06-24-2015 09:03 AM
Ancient Member
Yes, confirmed fixed. Nice!

+ Reply