Game errors when trying to wish for aols with ring of djinni summoning
issueid=4271 02-08-2016 02:30 PM
Junior Member
Number of reported issues by Zodi: 2
Game errors when trying to wish for aols with ring of djinni summoning

Trying to use blessed ring of djinni summoning and wishing for "amulet of life saving" results in error report instantly after pressing enter to confirm wish.

Repeated twice from backup save.

Issue Details
Issue Number 4271
Project ADOM (Ancient Domains Of Mystery)
Category Windows 10 (Steam)
Status Fixed
Priority 2
Affected Version ADOM r64 (v2.0.3)
Fixed Version ADOM r66 (v2.2.0)
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

02-08-2016 05:27 PM
Senior Member
Error and descriptions sounds a bit like - was the ring unidentified? Where did you try to use it?

02-08-2016 06:28 PM
Junior Member
Used it at D:16 next to khelly, the ring was identified. Gave it a few more gos and all resulted in error.

Removed all worn items and moved away from khelly, tried again and the wish worked.

02-08-2016 08:46 PM

02-09-2016 12:15 PM
Senior Member
Would help a lot if you shared that backup save file.

02-10-2016 10:07 PM
Junior Member
Encountered the same problem again, trying to finish ultra and im at chaos gate. Cannot use wishes / magical writing sets, both of them results in crash. Ill have a look at it tomorrow.

Has been a tough run, had to kill filk and emperor moloch twice due to magical writing set crash earlier. Feels scummy to load backup saves, even thou it is resulting from a crash :(

Copied the backup save @ D50 in case someone wants to see whats up, dont want to put it on public link.

02-11-2016 09:44 AM
Junior Member
Magical writing set worked if equipped and used with the use key, otherwise resulted in crash.
RODS worked if dropped to ground all equipped items and items from inventory. Just clearing equipped items didn't work.

Cba testing more, just wanted to finish ultra.

06-12-2016 09:31 PM
The Creator
This has been fixed a while ago. I can find the ticket ID right now. Works in R66.

+ Reply