Keyboard command sequence must be defined
issueid=968 05-05-2012 12:20 PM
jt jt is offline
Number of reported issues by jt: 148
Keyboard command sequence must be defined

Upgraded from ADOM II 0.2.3 to 0.2.5 on OSX (happens on Windows 7 too). Chose "ADOM classic" keybindings (see Whenever I try to save, either by using "Save Game" from the menu or by pressing SHIFT+S, the following exception occurs.

A controlled JADE error occurred.
Please see the stack trace for details.

de.adom.jade.JadeError: The keyboard command sequence 'y' must be defined!
	at de.adom.jade.ui.ascii.AsciiUserInterface.really(SourceFile:3217)
	at de.adom.jade.ui.commands.CommandSave.executeMetaCommand(SourceFile:50)
	at de.adom.jade.ui.commands.MetaCommand.executeImpl(SourceFile:55)
	at de.adom.jade.ui.commands.Command.execute(SourceFile:621)
	at de.adom.jade.beings.brains.PCBrain.doActImpl(SourceFile:154)
	at de.adom.jade.beings.brains.AbstractBrain.doAct(SourceFile:400)
	at de.adom.jade.beings.Being.actImpl(SourceFile:831)
	at de.adom.jade.kernel.actors.AbstractActor.act(SourceFile:58)
	at de.adom.jade.kernel.actors.ActorReference.act(SourceFile:60)

--- System information: ---

jnlpx.remove: 'null'
file.encoding.pkg: 'null'
java.home: 'null' 'null' 'null' 'null'
sun.java2d.d3d: 'false'
deployment.console.startup.mode: 'null'
jnlpx.offline: 'null' 'null'
java.endorsed.dirs: 'null' 'null' 'null'
deployment.javaws.concurrentDownloads: 'null' 'null'
sun.os.patch.level: 'null'
java.vendor.url: 'null' 'null' 'null'
deployment.javaws.home.jnlp.url: 'null'
java.version: 'null'
deployment.javapi.trace.filename: 'null'
deployment.max.output.file.size: 'null'
java.vendor.url.bug: 'null' 'null'
java.protocol.handler.pkgs: 'null'
javaplugin.proxy.config.type: 'direct'
deployment.user.tmp: 'null' 'null'
deployment.user.logdir: 'null' 'null'
deployment.browser.path: 'null'
deployment.cache.max.size: 'null'
sun.jnu.encoding: 'null' 'null'
jnlpx.home: 'null' 'null' 'null' 'null'
ftp.nonProxyHosts: 'null'
user.timezone: 'Europe/Berlin' 'null'
deployment.proxy.override.hosts: 'null'
path.separator: 'null'
deployment.javaws.installURL: 'null'
deployment.javaws.ssv.enabled: 'null'
jnlpx.heapsize: 'null'
file.encoding: 'null' 'null'
socksNonProxyHosts: 'null'
deployment.javapi.log.filename: 'null'
deployment.user.cachedir: 'null'
deployment.browser.args: 'null'
deployment.javaws.cache.update: 'null' 'null' 'null'
deployment.version: 'null'
user.language: 'null'
line.separator: 'null' 'null' 'null'
jnlpx.jvm: 'null' 'null' 'null'
deployment.max.output.files: 'null'
deployment.update.mime.types: 'null' 'null' 'null'
http.nonProxyHosts: 'null' 'null'
deployment.proxy.type: 'null' 'null' 'null'
deployment.javaws.shortcut: 'null'
java.awt.printerjob: 'null' 'null'
deployment.javaws.autodownload: 'null'
deployment.proxy.bypass.local: 'null'
http.auth.serializeRequests: 'null'
gopherProxySet: 'null' 'null'
deployment.javaws.logFileName: 'null' 'null'
java.specification.vendor: 'null'
deployment.javaws.uninstall.shortcut: 'null' 'null' 'null' 'null' 'null'
java.quick.starter: 'null'
mrj.version: 'null' 'null'
java.library.path: 'null'
java.class.version: 'null'
sun.awt.exception.handler: 'null'
deployment.control.panel.log: 'null' 'null'
deployment.trace: 'null' 'null' 'null'
deployment.javapi.cache.update: 'null'
deployment.cache.jarcompression: 'null' 'null' 'null'
deployment.javaws.update.timeout: 'null'
sun.boot.library.path: 'null' 'null'
java.awt.graphicsenv: 'null'
deployment.user.extdir: 'null' 'null' 'null'
deployment.proxy.same: 'null' 'null'
deployment.javaws.traceFileName: 'null' 'null'
java.vm.specification.version: 'null' 'null'
awt.toolkit: 'null'
sun.cpu.isalist: 'null'
java.ext.dirs: 'null'
os.version: 'null'
user.home: 'null' 'null'
trustProxy: 'null'
java.vm.vendor: 'null'
deployment.javapi.lifecycle.exception: 'null'
user.dir: 'null'
deployment.cache.enabled: 'null'
sun.cpu.endian: 'null' 'null'
deployment.javaws.splash.index: 'null'
java.vm.version: 'null' 'null'
java.class.path: 'null'
os.arch: 'null'
deployment.javapi.stop.timeout: 'null'
deployment.mime.types.use.default: 'null' 'null'
java.rmi.server.RMIClassLoaderSpi: 'null'
deployment.capture.mime.types: 'null'
javawebstart.version: 'null' 'null' 'null'
deployment.javaws.muffin.max: 'null'
deployment.log: 'null'
https.protocols: 'null'
java.vm.specification.vendor: 'null'
file.separator: 'null'
java.runtime.version: 'null'
sun.boot.class.path: 'null' 'null' 'null' 'null' 'null'
deployment.repository.enabled: 'null' 'null' 'null'
deployment.javapi.runtime.type: 'null'
deployment.javaws.associations: 'null'
java.vendor: 'null'
awt.nativeDoubleBuffering: 'null'
java.specification.version: 'null' 'null' 'null'
Issue Details
Issue Number 968
Project ADOM II (formerly known as JADE)
Category UI
Status Fixed
Priority 6
Affected Version ADOM II 0.2.5
Fixed Version ADOM II 0.2.6
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

05-05-2012 05:41 PM
I've found that keyboard errors happen if you don't choose the ADOM II keyset mapping first. Choosing this option will map all keys... then you can choose whatever mapping you want.

05-06-2012 11:58 AM
The Creator
Fixed for ADOM II 0.2.6. Please send your real name to creator(at) for it to be included in the credits. (If you were already asked to do so you can ignore this message. Please include a reference to the bug or RFE you are credited for.)

+ Reply