unable to unlock ADOM_HS.LCK
issueid=6410 12-05-2018 07:50 PM
Number of reported issues by fitzpa88: 4
unable to unlock ADOM_HS.LCK
can't resolve HighScore in use; unable to add entries or view scores

For a while, I got the error message "highscore is currently in use by another process". That has now advanced to:
"The highscore has been locked for a long time (lock file C:\...\ADOM/adom_steam/ADOM_HS.LCK'). Some kind of problem with another ADOM process might be the reason for this. You might be in trouble.
Do you want to
[w] wait some more time
[q] quit without saving the highscore
[f] force saving the highscore (warning: this might damage your highscore file)

If I press W, the error recurs after maybe 10 seconds. Q 'works' by bypassing the highscore, I see the message "You didn't make it into the highscore. At least 1 point was required." If I press F, I get a third error message:

An error occurred:
Can't read highscores completely.
A file called 'adom.err' will be created....

I looked for prior guidance on this issue, and from https://www.adom.de/forums/project.php?issueid=2159 I started by deleting ADOM_HS.LCK.

It seems to...regenerate itself when I open the game.

Second, by following instructions in forums/projectphp?issueid=6165, I
-removed HIGHSCOREM from the ADOM directory and then also
-deleted ADOM_HS.LCK

It hasn't changed the behavior of the ADOM software. My folder currently contains no HIGHSCOREM. I can open and play, but if a character dies, it jumps straight to the "Can't read highscores completely." message, and there's a new ADOM_HS.LCK file.

I unfortunately do not know how to embed an error file, but would appreciate guidance on how to get the high score functioning again.
Issue Details
Issue Number 6410
Project ADOM (Ancient Domains Of Mystery)
Category Windows 8
Status Unconfirmed
Priority 3
Affected Version ADOM 3.3.2
Fixed Version (none)
Milestone (none)
Users able to reproduce bug 2
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

12-14-2018 12:59 AM
Junior Member
I've had this same error but running on Mac.

12-21-2018 05:19 PM
Selfishly, I really hope for some guidance on this issue. I have a gate-closer who hasn't left the chain yet, because I'm pretty sure right now he won't be saved in my high scores....

12-21-2018 07:18 PM
jt jt is offline
When do you get this error? When you start ADOM? When you try to view your current highscores?

There are different highscore files for each game mode. Can you view the highscores for each game mode in ADOM?

12-22-2018 09:31 AM
Junior Member
The error appears after a character has died. It appears right before the screen that allows you to select view inventory, main menu, etc.

I only ever play the rogue-like option and when trying to view any high score, nothing happens and the game is effectively locked. There are no responses and the only option is to kill the game by force quitting it. I may have damaged my high score list by selecting the force save option.

As documented above, there are three options. I've tried all of them.
Waiting results in returning to the same error screen with the same options although it now says that the file has been locked for a long time. Some kind of problem with another ADOM process might be the reason for this. You might be in trouble.

I may have damaged my high score file as one of the options from the error screen is to to force save. This causes the game to crash. Upon restarting, I can then load the game in which the character died but it goes through the death sequence again. Only once did it not do this and I could effectively play on.

The only real option is to quit without saving. This enables the game to get back to the main menu as documented above.

I'm happy to provide any other information you want.

12-22-2018 02:40 PM
jt jt is offline
Roguelike mode uses the highscore file named "HISCORE". I would recommend moving the file to a different location and also to remove the "ADOM_HS.LCK" if it is in the directory.

Then start ADOM and quit it again. This should trigger a download of all your highscores from the server. Once ADOM has done that you can start it ADOM again. Now everything should work again.

How big is the "HISCORE" file?

12-22-2018 07:27 PM
As SwiftFingers said, I cannot view any high scores. In fact, if I click to view high scores, then NO buttons (including 'back to main menu') do anything, and I have to force-close ADOM.

I removed HISCORE and HS.LCK to another location, opened and quit ADOM, opened and rolled a new character. When he died, he was put in the high score as my FIRST high score. The HISCORE file that I moved to an alternate location is only 4 bytes, if that matters.

So...good news, new scores will be saved; bad news, I lost my first two victories and my first Ultra from my high score, at least in what I can see right now.. Is there a way to explicitly tell the ADOM software to pull my scores from the server?

Thank you for helping both of us!

12-24-2018 02:50 AM
Junior Member
I'm having the same problem (playing on Steam on Mac OS X 10.10.5 if it matters), and in addition to the above problems, the character's file will reappear in my saved games, though from hours back (from the last time I loaded the game, I think).

It also says that the LCK file is under /Users/(my computer name)/Library/ADOM/adom_steam/ADOM_HS.LCK, but I couldn't find the file; I don't think the directory exists. I'm only moderately savvy in this area, but unless something is being hidden from me, I don't have the Library directory. Could the error be because the game is trying to save to a location that doesn't exist?

Hope this helps.

12-24-2018 04:23 PM
Junior Member
I've followed your instructions jt and I can now select the highscores and not have the program lock on me. As fitzpa88 has said, there are no high scores now. I don't really care about that. It's just nice to not have the error now.

Chilxius, that location should exist on your mac. Are you looking in the System library or your user library? It definitely exists in mine. You should be able to use shift-cmd-G in the Finder (this is the command to go to a particular folder) to take you to that location. If you can do that and remove the highscores file, you should be able to play without error.

I'll update if there are any further issues.

12-24-2018 04:40 PM
Junior Member
Ha! I spoke too soon. Played through first death after deleting the high scores and upon death got an error that said invalid JSON character. The game then crashed an on restart I could load the character at the death sequence. Clicked through and got the same highscore error as above. I'll try again.

The high score file is only 4 bytes.

12-24-2018 05:14 PM
Junior Member
Sorry, the error received is JSON: Invalid UTF-8 character

I did notice that starting ADOM and quitting didn't seem to trigger the highscore file to come back. This seems to be when the JSON error is generated. Deleting both files doesn't seem to have rectified the problem.

01-02-2019 11:23 PM
Junior Member
Found my Library folder. Apparently Mac sometimes hides it. (If anyone is seeing this in the future, hold option when bringing down the Go dropdown menu in Finder and it should appear).

I also got the JSON error, though. Sounds the same as Swiftfingers.

01-09-2019 12:54 PM
Junior Member
I'm having the exact same issue as these guys. I get the message " "highscore is currently in use by another process" and the same three options as mentioned above: wait, quit, or force.
Because I'm a noob who rarely lives to see Level 8, it's more annoying to have to wait to start a new game than it is not having a high score listing, but if I ever get better at this game, it would suck not being able to save a decent high score.

01-10-2019 04:17 PM
The instructions above "worked" in that I can now save new high scores, but I don't appear to have ever recovered prior save files. So my first 2 gate-closers and my first Ultra aren't in my high score list any longer. Is there any way to actively go fetch them from servers?

Thanks again.

01-19-2019 02:51 AM
wes wes is offline
Junior Member
I'm having the same issue. I'll attach my adom.err file.

01-19-2019 06:02 PM
wes wes is offline
Junior Member
Are the other folks who are experiencing this also having trouble with ADOM syncing? Everytime I quit the game, it gets stuck on the "Communicating with ADOM server" screen and I have to force quit.

01-22-2019 04:43 AM
Junior Member
wes, I don't seem to have that issue.

05-13-2019 03:26 PM
Junior Member
Quote Originally Posted by wes
Are the other folks who are experiencing this also having trouble with ADOM syncing? Everytime I quit the game, it gets stuck on the "Communicating with ADOM server" screen and I have to force quit.
I have the same issue. Hoping to get a fix for this!

+ Reply