Mist Elf won't finish action (while taking damage from iron) despite Y to all prompts
issueid=6274 06-23-2018 09:16 PM
Junior Member
Number of reported issues by fitzpa88: 3
Mist Elf won't finish action (while taking damage from iron) despite Y to all prompts
if you press Y to all prompts on if you want to continue an action despite iron damage, sometimes the action is still not taken

Using r97, I have a mist elf who has (deliberately) equipped an iron item, intending to complete one or more actions, and then take the item off. The game prompts with whether I want to continue, and I press Y as it drops from a larger number of turns remaining to zero, but after pressing Y the last time, the action is not completed.

I've run into this a couple of times before but unfortunately don't think I can provide detail on when it does/doesn't occur. Previously, it happened with reading a spellbook [put on Crown of Science, knowing that I had enough HP to take advantage of LE boost to read ball spells, heal myself, read another book, heal myself, and repeat until I finished and took the crown off], which despite pressing Y to all of the prompts, I didn't successfully read the spell [high level wizard, reading a spell I already had spell knowledge over 800]].

The current event, though, will kill my character if it's not resolved. I have a mist elf who equipped armor [Chainmail of the Martyred Crusader; decided to see how rapidly I took damage to figure out if I could wear it at tactically-chosen times]. The action that is being interrupted/failing to complete is removing the armor.

I open inventory, press C to remove the armor, get a prompt that I take damage and do I want to continue (7 turns remaining), press Y seven times....and then still have the armor equipped. I tried a couple of times, closed and opened ADOM and tried again, so I'm down to half hit points.

I'll just leave this character paused until this bug is resolved!
Issue Details
Issue Number 6274
Project ADOM (Ancient Domains Of Mystery)
Category Windows 10
Status Duplicate
Priority Unknown
Affected Version ADOM 3.2.2
Fixed Version (none)
Milestone (none)
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




06-24-2018 12:51 AM
Ancient Member
Duplicate of 6154

06-25-2018 12:16 PM
Junior Member
This is 100% a duplicate entry. Thank you, Grond, for linking me to the correct already-numbered bug.

+ Reply