No animation for "icy blast" from ogre magi
issueid=1881 01-28-2013 10:16 PM
Senior Member
Number of reported issues by BenMathiesen: 96
No animation for "icy blast" from ogre magi

I lured an ogre mage down to the tomb of the High Kings, and despite numerous icy blasts in my direction no water behind me froze.
Possibly related, I no longer see the "icy blast" ray animation, although the Frost Bolt and Wand of Cold produce a ray as normal. The wand of cold I found did freeze the water.
Issue Details
Issue Number 1881
Project ADOM (Ancient Domains Of Mystery)
Category All
Status Fixed
Priority 10 - Lowest
Affected Version ADOM 1.2.0 pre 10
Fixed Version ADOM 1.2.0 pre 11
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




01-28-2013 11:48 PM
jt jt is offline
Administrator
I can confirm the "icy blast" animation problem (it's played way too fast so it's nearly invisible). I summoned an ogre magus to Terinyo and the water froze correctly while he targeted me, so maybe the problem is related to the location!?

01-28-2013 11:53 PM
Senior Member
In previous releases of the game Ogre Magi would be able to freeze the water in the ToTHK, so it's either a location-related problem, or TB deliberately disabled it on that level for some reason. Are Ogre Magi still able to freeze multiple squares of water with a single blast? If that got changed/fixed, it might be related...

01-29-2013 11:51 PM
jt jt is offline
Administrator
Quote Originally Posted by Dogbreath
Are Ogre Magi still able to freeze multiple squares of water with a single blast?
Yes, that is still happening.

01-30-2013 07:35 AM
Senior Member
The character who observed this also had the "cold blood" corruption, and was down to speed 10 at the time. Well, something to keep an eye on I guess.

01-31-2013 04:20 AM
Ancient Member
Quote Originally Posted by BenMathiesen
The character who observed this also had the "cold blood" corruption, and was down to speed 10 at the time. Well, something to keep an eye on I guess.
can we fix the bug where white dragon breath doesn't freeze properly?

01-31-2013 08:34 AM
Ancient Member
I'll just chime in to say that yesterday I did the piranha lake on 1.2.0p9 with an ogre magus, and he froze the water as usual (although with no visible animation). So if they really no longer freeze water, it must be a p10-specific bug.

01-31-2013 08:48 AM
Ancient Member
despite numerous icy blasts in my direction no water behind me froze.
Hang on.. behind you? If a cold blast hits you it doesn't travel further (they're not like breath attacks). The blast has to pass over the lake before it hits you to freeze water.

01-31-2013 06:04 PM
Senior Member
I don't remember having to do that in earlier versions, but I've only tried to get an ogre magus to make a bridge for me once or twice in the past.

So normally, you have to get on the other side of the lake from the OM, and hope he blasts a bridge across trying to reach you?

01-31-2013 06:48 PM
Ancient Member
Quote Originally Posted by BenMathiesen
So normally, you have to get on the other side of the lake from the OM, and hope he blasts a bridge across trying to reach you?
Yes. Or rather, get a few squares of water between you and the magus, and make him start "cutting corners" with its bolt, until the lake is smaller and then you can do that.

01-31-2013 10:00 PM
Senior Member
'Cool'!

OK, I withdraw the bug. Thanks everyone.

02-03-2013 08:59 PM
jt jt is offline
Administrator
Closed as "fixed" because the ice blast animation was corrected.

+ Reply