ADOM overloads processor while minimized
issueid=4117 11-28-2015 09:52 PM
ixi ixi is online now
Junior Member
Number of reported issues by ixi: 51
ADOM overloads processor while minimized

I used to play ADOM when I have free time from work and other activities. I often read forums or chat and skype while playing. That's why I often have to minimize ADOM.

However ADOM does something even while minimized, one of my processor core is always fully occupied by ADOM!

This drains my laptop battery pretty fast, forces fan to work (usually my laptop can be completely silent) and sometimes even leads to overheating.
It's fine if NotEye requires all processor capabilities during the game but why these activities can't be suspended while ADOM is minimized?

For now most of the time I have to save and quit ADOM if need just to switch.

AFAIK this is happening for all recent versions with NotEye (both normal and Steam). I'm using Windows 7.
Issue Details
Issue Number 4117
Project ADOM (Ancient Domains Of Mystery)
Category Windows 7 (Steam)
Status Fixed
Priority 2
Affected Version ADOM r64 (v2.0.3)
Fixed Version ADOM 2.3.0 (r73)
Milestone "Ease of Use" UI
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users jt, Zeno
Tags (none)




11-29-2015 02:45 AM
Junior Member
True, I see similar on Win7. Caveats are I have ADOM set to 100% processor usage, I have a hexcore with cores undocked, and adom indeed shows 1/6 (17%) overall processor usage, even if rather spreadout than on a single core.

12-28-2015 08:55 AM
The Creator
To me it seems that this also happens when using several desktops on the Mac (at least on my Mac). My suspicion is that some NotEye loop gets out of control. We need to investigate...

09-09-2016 10:50 AM
ixi ixi is online now
Junior Member
Hi Thomas!

How far are you with the investigation? This is the only issues stopping me from playing ADOM now.

06-23-2017 09:26 PM
Ancient Member
Fixed by adding a sleep when the game is maximized or out of focus; this might be not perfect if something is performed in the background, as then that action gets slowed too. One example of such a background action is the preloading of graphics -- I have disabled CPU saving in this case, so you can safely switch focus while preloading and it will not slow down.

I see no SDL window event other than focus lost sent when switching workspace on Linux -- so I have decided to slow down the loop in this case too. Animations are now disabled in this case, because low-framerate animations would look weird.

06-24-2017 06:43 AM
ixi ixi is online now
Junior Member
Thank you Zeno. Will make sure to retest this on Windows and Linux Mint Cinnamon once version is available.

I still wonder would could be the root cause though...

+ Reply