Minimap issue
issueid=2861 04-21-2014 02:55 PM
Number of reported issues by theseus12: 32
Minimap issue

So I was running Prerelease 21 on a Windows XP Computer. I was just dicking around with the noteye features, checking everything out, when the game suddenly just... closed. Aware of the possibility that it could just be the fact that this is a very old, very buggy computer (Which is what I assume happened on my last bug report concerning Admin the Fallen Dwarven Paladin who kicked trolls to death), I pulled it back up and tried again, repeating the last action I had done. the moment I exited the Noteye menu, the game window closed itself, and my character was gone. At least this time it was level one, not a level seven. What was I messing with? The minimap. But, two crashes from the same occurences were hardly evidence, so I decided to test a third time. Sure enough, it crashed, and it did it several more times as I wrote out a guide to duplicate this little issue.

How to duplicate:
1.) Turn on ADOM (v.1.2.0 Prerelease 21, if I need to get technical. Unlikely, but...)

1.5) If you're the kind of person who runs the game fullscreen, feel free to. This happens either way, I checked.

2.) Follow all steps to make a new character that you usually perform. (Trust me, you want to do it this way as opposed with a savegame)

3.) Hit F8 to open the Noteye menu. (Well, one of them. Another would be F9.)

4.) Hit "m" to toggle the minimap. This makes many useful features on the map, and can range from classic ASCII to regular tile format to isometric to even a working First Person Perspective (though admittedly very slow running when the map is in this way)

5.) Set to minimap mode: blocks

6.) Exit the Noteye menu, through hitting the spacebar, Esc key, or Enter key

7.) Hope the new character you made wasn't one that had potential. But Hey, Presto! Ta-Da! You've just made your character dissapear! It's Magic!

Or I called it right, and this is a bug. What do you guys think? My money goes on bug. Anyone with systems other than Windows XP, if you can duplicate this bug, I ask that you leave a comment on the thread about which system is also affected. Might be related to XP only, might affect them all, I dunno. All I know is that I would rather that this be taken care of. Thanks for listening to me ramble!

Note: All other minimap modes seem to run correctly in this version. It is only in blocks mode that the game suddenly kills itself off.

Discovered 4/20/2014 at about 05:45 hours.
Issue Details
Issue Number 2861
Project ADOM (Ancient Domains Of Mystery)
Category All with NotEye
Status Fixed
Priority 4
Affected Version ADOM 1.2.0 pre 21
Fixed Version ADOM 1.2.0 pre 23
Milestone (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users jt
Tags (none)

04-22-2014 04:35 PM
jt jt is offline
It's a NotEye problem which needs to be fixed by Zeno. Temporarily deactivated the minimap "block" mode.

04-22-2014 04:48 PM
So its not the actual game?

04-22-2014 05:20 PM
jt jt is offline
No, actually a function in NotEye crashes while trying to display an error message. But I don't know where the error comes from, so it's probably best to let Zeno fix it. ;)

04-30-2014 07:40 PM
jt jt is offline
Zeno fixed it.

+ Reply