Release 57 says "Release 52" in the splash screen
issueid=3714 05-20-2015 07:19 PM
Junior Member
Number of reported issues by Nuteater: 2
Release 57 says "Release 52" in the splash screen
Release 57 says "Release 52" in the splash screen and when using 'adom -v'

I was about to report another bug when I decided to check that I am running the latest version.
I remember upgrading a little while ago, but was then surprised to see "Release 52" printed on the
ncurses version splash screen. Also, the command 'adom -v' shows:

Ancient Domains Of Mystery -- Release 52
(C) Copyright 1994-2014 Thomas Biskup.
All Rights Reserved.

Ancient Domains Of Mystery Release 52

Build: Apr 11 2015 12:42:05

I tried re-installing the latest prerelease from adom_linux_debian_64_r57.tar.gz downloaded
from the super secret secure site, and still, "Release 52". The build date indicates it is still probably
release 57, or at least the build date matches the release date of version 57.
Has the version number been intentionally not incremented, or what is going on?
Issue Details
Issue Number 3714
Project ADOM (Ancient Domains Of Mystery)
Category Linux
Status Fixed
Priority Unknown
Affected Version ADOM r57
Fixed Version ADOM r58
Milestone (none)
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




05-20-2015 09:24 PM
Junior Member
Downloaded the same file and I see the same thing. adom_linux_ubuntu_32_r57.tar.gz shows r56; adom_linux_ubuntu_64_r57.tar.gz shows r57.

05-24-2015 07:12 AM
Junior Member
Is there some easy way to confirm which version all these executables really are?

I tried installing adom_linux_ubuntu_64_r57.tar.gz as well, which shows R57 on the splash screen as etymancer said.
I am able to load saved games from the Debian version (which says R52), so I guess the versions could be same, or
at least close.

On the other hand, the Debian version appears to have no achievements ('A' in start screen gives
"You have unlocked 0 of 0 achievements."), while the Ubuntu version shows a long list of achievements.
Then again, the Ubuntu version has no "[E] Change settings." or "[L] Repeat last game." on the start screen.

I thought these different ADOM versions (Ubuntu and Debian with various numbers of bits) are compiled from
the same source code. What really is going on?

05-26-2015 05:43 PM
jt jt is offline
Administrator
That's really odd. The build system consists of about 18 virtual machines and the process is fully automated (it would takes ages to build all different versions manually). But I always do a manual checks of the logfiles after the builds are complete to verify that all binaries use the same revision.

I will check the build scripts and logfiles.

Update: in some cases the subversion update failed and I didn't notice the error message in the logfiles. Here is a list of builds that may (!) not contain the latest R57 version:

Code:
adom_freebsd_32_r57
adom_freebsd_64_r57
adom_linux_debian_32_r57
adom_linux_debian_64_r57
adom_linux_ubuntu_32_r57
adom_linux_ubuntu_64_r57
adom_msdos_r57
adom_netbsd_32_r57
I will think of a way to improve the build process to make it even safer in the future. R58 will hopefully be released soon.

07-23-2015 05:14 PM
jt jt is offline
Administrator
I've added more security check to all scripts which will prevent problems as this in the future.

+ Reply