Ghost keypresses on Linux
issueid=5077 09-21-2017 01:48 AM
Qui Qui is offline
Senior Member
Number of reported issues by Qui: 98
Ghost keypresses on Linux

I have a strange problem with ADoM on Linux (first misdiagnosed in There's a good chance it's unique to me, thus very low priority. If there's no easy solution, I'll just stick to emulators.

Basically, I cannot use anything requiring multichar input (taking to dwarf, wishing, naming/renaming my character). Looks like the game reads some keypresses that I'm not doing. I have following clues:
1. It happens in old versions of ADoM too, checked back to 1.1.1. These are noticeable in versions before 2.3.0, as pictured on the screenshot. It refreshes constantly, blinking in effect. In 2.3.0 and higher, the "Unknown command" and the blinking are gone.
2. I used to play ADoM on this machine without issues in the past. Possible causes could be keyboard replacement or system upgrade (to Ubuntu 16.04).
3. I ran ADoM DOS version through DOSBOX, and Windows version through both wine and VM. No issue. Looks like only Linux version is affected.
4. No other software is affected, and I use console a lot.
5. I tried various keyloggers, they log nothing unusual.

The only idea I have left is that the Linux version of ADoM has some unusual input method that reads some erroneous signals from my new keyboard that everything else filters out... which feels like a stretch, but I thought I'd ask.
Issue Details
Issue Number 5077
Project ADOM (Ancient Domains Of Mystery)
Category Linux
Status Fixed
Priority 10 - Lowest
Affected Version ADOM 2.3.2
Fixed Version ADOM 2.3.3
Milestone (none)
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users jt
Tags (none)

09-21-2017 07:58 AM
jt jt is offline
Fixed for 2.3.3. I could only reproduce this on my Ubuntu VM, not on my PC with Ubuntu. It may be a change in the curses library of Ubuntu, but NOT calling "notimeout()" to disable the "getch()" timer works.

We added a workaround for version 2.3.0. This is the reason that the "unknown command" wasn't shown anymore.

09-21-2017 03:47 PM
Qui Qui is offline
Senior Member
Thanks a lot Jochen, much appreciated!

+ Reply